1. 金融知识学习网 > 外汇知识学习 >

macd红柱选股公式

本文有2032个文字,大小约为6KB,预计阅读时间6分钟

本文地址:http://www.bjeol.cn/waihui/14208.html

本文标题:macd红柱选股公式

本文关键字:dea,macd,macd指标,macd金叉

MACD指标是所有技术指标中最经典的一个技术指标。运用MACD结合K线、个股走势、量、大盘走势等。基本上都能达到较好得买卖效果。

今天给大家讲解如何运用MACD进行选股:

1、零轴上方第一次金叉:

黄白线在零轴上方第一次金叉的准确率是非常高的。这是极佳的买点。

零轴上方第一次金叉

DIFF:=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA:= EMA(DIFF,9);

MACD:= 2*(DIFF-DEA);

SELECT:CROSS(DIFF,DEA) AND DEA>-1.0 AND DEA<0.5 AND CLOSE>REF(CLOSE,1) AND CLOSE>=MA(C,60);

2、零轴上方二次金叉:

通常第一次金叉涨幅有限。那么零轴上的第二次金叉。尤其是突破前高之后的第二次金叉。爆发力会更强。是主升浪的开始

零轴上方二次金叉

JC:IF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)>REF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);

3、零轴下方一次金叉:

零轴下方一次金叉

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=(DIFF-DEA)*2;

低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;

4、零轴下方二次金叉:

当DIF、DEA指标都处于零轴以下时。如果短期内(8或13个交易日内)连续发生了两次金叉。很容易出现暴涨行情的。低位二次金叉出现暴涨股得概率要比低位第一次金叉要高。

零轴下方二次金叉

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

AA:=BARSLAST(REF(CROSS(DIF,DEA),1));

二次金叉:CROSS(DIF,DEA) AND DIF>REF(DIF,AA+1) AND AA<20 AND DIF<0;

5、四线金叉预警选股公式(均线、KDJ、均量线、MACD金叉):

(1)5日线上穿10日线;

(2)MACD金叉;

(3)KDJ金叉(KDJ数值调整为8、2、2);

预警公式:

四线金叉

A1:=CROSS(MA(C,5),MA(C,10));

A2:=CROSS(MACD.DIF,MACD.DEA);

A3:=CROSS(KDJ.K(8,2,2),KDJ.D(8,2,2));

A4:=CROSS(MA(V,5),MA(V,10));

XG:A1 AND A2 AND A3 AND 4;

6、佛手向上:DIF与DEA金叉之后。随股价上行而向上。接下来又跟着股价回调而向下。这通常是主力洗盘的时候。股价回调使得DIF回调到MACD线附近之后。DIF线立即调头向上。形成了佛手向上的形态。

双佛手向上选股公式:

1、DIFF线回调DEA线附近时不死叉。又调头向上;

2、30日均线走平或向上。同时5日线和10日线在30日线上方金叉,且当日收阳线;

3、5日均量线回调到34日均量线附近时不死叉,又调头向上;

佛手向上

A:=L/HHV(H,10)<0.88;B:=EVERY(C>O,3)=1 AND REF(C,3)<REF(C,4) AND C/REF(C,3)<1.08;

XG:COUNT(A,3) AND B AND L>MA(C,5) AND O>MA(C,5);

7、漫步青云:

DIF线在零轴上死叉DEA线。继续下穿零轴。在零轴或者零轴以上金叉DEA。这时候的K线形态通常是穿越了或正在穿越重要均线。该形态的形成是股价在探底回升途中做盘整。也会是筑底形态。呈现上攻之势。看多信号。

漫步青云

DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);

DEA := EMA(DIFF,27);

dje:=DIFF>=0 and DEA>=0 and CROSS(DIFF,DEA);

a5:=MA(CLOSE,5)>MA(CLOSE,10);

v5:=VOL>MA(VOL,5) and MA(VOL,5)>MA(VOL,10);

dje and a5 AND V5 AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1)

主要用法:当30日线走平或者上扬。5日均量大于10日均量。当日成交量大于5日均量。5日均线金叉或者已经金叉10日均线。MACD指标中DIF线在零轴之上死叉DEA线。DIF线下穿零轴之后。又再次上穿并且在零轴或零轴上金叉DEA线。这时候可以介入。

8、空中缆绳:

MACD指标中的DIFF之前在零轴之下金叉DEA线。之后在零轴之上运行了一段时间。然后跟随股价回调。DIF也开始向下回调。当DIF调到了DEA线时。两线粘合成一条线。当他们再次分离多头发散时。就出现了买入的机会。

空中缆绳

DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);

DEA := EMA(DIFF,27);

MACD := 2*(DIFF-DEA);

b:=MIN(DIFF,DEA)/MAX(diff,dea)>0.95;

MA(CLOSE,30)>REF(MA(CLOSE,30),1) and diff>0 and dea>0 AND MACD>REF(MACD,1) and b

MACD参数设定为sh:12;long:26;M:27。

主要用法:30日均线上扬或走平。主力开始洗盘。这时候MACD指标中的DIF线随着股价回调而与DEA线在零轴上粘合数值几乎相等。只要5日均线在30日均线上方金叉或已经金叉10日均线。MACD指标红柱加长。DIF线脱离DEA线上扬。就是买点机会。

macd红柱选股公式

1、MACD连续翻红公式:

DIF:=EMA(CLOSE,8)-EMA(CLOSE,13);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

A1:=MA(C,5);

A2:=MA(C,10);

A3:=MA(C,30);

A4:=COUNT(A1>A2 AND A2>A3,3)=3 AND REF(A3,1)<REF(A3,2)AND A3>REF(A3,1);

A5:=CROSS(C,A4)OR C>A4;

A6:=VOL>MA(VOL,5);

选股:A4 AND A5 AND A6 AND CROSS(DIF,DEA);

MACD连续二次翻红指标技巧

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);

FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;

FH3:=EMA(C,30)>=REF(EMA(C,30),1) AND COUNT(EMA(C,5)>EMA(C,10) AND EMA(C,10)>EMA(C,30),1)=1;

FH4:=CROSS(C,EMA(C,30)) OR C>EMA(C,30);

FH5:=FH1 AND FH2 AND FH3 AND FH4;

FH6:=FH1 AND FH2 AND FH3 AND FH4 AND ABS((DIFF-DEA)/C)<0.018;

FH7:=FH1 AND FH2 AND FH3 AND FH4 AND MACD<0.10;

FH5 OR FH6 OR FH7;

如果您满足MacDDoubleTurnRed并满足以下标准。则库存中的短期增长很可能是大的:

1当股票大幅下跌时。MacD的第二圈通常会出现。而MacD在绿色列中消失。当红色列出现时。即第一次红色列翻转时。MACD在0轴下方运行。在这一点上。它已在0轴下方形成了一个MacDGold叉。并在几天后在0轴上方运行。如果它超过0轴。效果就更好了。这是在0轴下方形成金叉。然后在上轴上方运行的先决条件。第二次。在MacD上出现一个小的红色列。当红色列继续放大时。在第5天。30天的移动平均值已从下降变为平坦或向上。10,30天的移动平均值刚刚形成多头排列。

2K线是更积极的。每天的K线刚刚越过30天的移动平均值。或者在30天的移动平均值之上运行。最好是在5天的平均值上。

还想获取更多关于"macd红柱选股公式"的内容可以阅读:

本文来源网络,地址:https://www.809030.com/baike/12493.html

联系我们

在线咨询:点击这里给我发消息

微信号:weixinhaoma

工作日:9:30-18:30,节假日休息